Welkom, Gasten
Gebruikersnaam: Wachtwoord: Onthoud mij

Onderwerp: Iungo via mqtt broker koppelen aan Domoticz

Iungo via mqtt broker koppelen aan Domoticz 4 maanden 3 weken geleden #1227

  • M ten Harmsen van der Beek
  • M ten Harmsen van der Beek's Profielfoto
  • Offline
  • Gold Boarder
  • Berichten: 247
  • Ontvangen bedankjes 43
kijk, vorderingen.Altijd van belang precies uit te vinden waar het fout gaat ;-)

heb je de log pagina van de Iungo ook bekeken? Daar kan je als het goed is zien wat er aan topics uit gaat.

eigenlijk kan je niet zo veel instellingen (en dus ook niet veel fout gaan) aan de kant van de Iungo, kan je een screenshotje maken van je instellingen? (even maskeren wat je prive gegevens zijn)

zou zo iets moeten zijn:

Laatst bewerkt: 4 maanden 3 weken geleden door M ten Harmsen van der Beek.
The administrator has disabled public write access.

Iungo via mqtt broker koppelen aan Domoticz 4 maanden 3 weken geleden #1228

  • J.W. Maijers
  • J.W. Maijers's Profielfoto
  • Offline
  • Berichten: 9
Hoi Marijn,

succes! :woohoo:

ik had achter het IP adres van de data broker ook het poortnummer staan:
in mijn geval dus 172.215.4.122:1883. Ik kon het poortnummer namelijk nergens anders kwijt.
Na het verwijderen van het poortnummer verschenen de Iungo topics vrijwel direct in de data-broker..

Hoe simpel kan het zijn! :S
enfin, belangrijke horde genomen lijkt me.

Maar nu toch weer die laatste stap. Hoe koppel ide Iungo topics aan de sensoren in Domoticz?
The administrator has disabled public write access.

Iungo via mqtt broker koppelen aan Domoticz 4 maanden 3 weken geleden #1229

  • M ten Harmsen van der Beek
  • M ten Harmsen van der Beek's Profielfoto
  • Offline
  • Gold Boarder
  • Berichten: 247
  • Ontvangen bedankjes 43
J.W. Maijers schreef :
Hoi Marijn,

succes! :woohoo:


Maar nu toch weer die laatste stap. Hoe koppel ide Iungo topics aan de sensoren in Domoticz?

Mooi!
Je moet de broker los zien van Domoticz. Domiticz moet je net zoals de Iungo richting die broker sturen. In Domitcz moet je derhalve dezelfde settings invoeren als in de Iungo. Althans, hetzelfde ip adres en inlog en paswoord.

dan zou je verder binnen domticz Mqtt sensoren moeten kunnen aanmaken. Hoe dat precies gaat weet ik niet, want ik gebruik geen domoticz.

In HomeAssitant heb ik voor alle Mqtt topics een dergelijke sensor aangemaakt:

- platform: mqtt
state_topic: 'MacAddress/energy-solar-sdm630-modbus/id/import'
name: 'ZP Import'
unit_of_measurement: 'kWh'
value_template: '{{ value | round(2) }}'

de waarden van het mac address en id kun je uitlezen in de log of nu in MQttfx

wellicht dat het in domoticz vergelijkbaar gaat?

schakelen gaat ook, alleen doen we dat via een api -instructie, dat is weer wat anders ;-)
The administrator has disabled public write access.

Iungo via mqtt broker koppelen aan Domoticz 4 maanden 3 weken geleden #1230

  • J.W. Maijers
  • J.W. Maijers's Profielfoto
  • Offline
  • Berichten: 9
Hoi Marijn,

ja klopt, het zijn verschillende pakketten. Dat weet ik.
In Domoticz kan ik ook een koppeling met de data-broker maken.

Deze gaat dan naar de poort domoticz/in luisteren.
Ik kan verder geen mqtt sensoren aanmaken. Wel virtuele sensoren die luisteren een idx nummer.

via node-red moet ik dus vermoed ik de data uit de iungo converteren naar:
Topic: domoticz/in, Message: {"command":"udevice","idx":658,"svalue":"3.4","nvalue":0}
bijvoorbeeld.

Maar hoe ik die koppeling moet maken, dat gaat mij boven m'n pet.
Rodney heeft in een e-mail aangegeven dat het hem gelukt is, dus ik zal het hem nog eens vragen hoe hij dat gegaan heeft.

Ik ben er bijna! :-)
Laatst bewerkt: 4 maanden 3 weken geleden door J.W. Maijers.
The administrator has disabled public write access.

Iungo via mqtt broker koppelen aan Domoticz 4 maanden 1 week geleden #1252

  • P. Meindersma
  • P.  Meindersma's Profielfoto
  • Offline
  • Expert Boarder
  • Berichten: 126
  • Ontvangen bedankjes 26
J.W. Maijers schreef :
Hoi Marijn,

ja klopt, het zijn verschillende pakketten. Dat weet ik.
In Domoticz kan ik ook een koppeling met de data-broker maken.

Deze gaat dan naar de poort domoticz/in luisteren.
Ik kan verder geen mqtt sensoren aanmaken. Wel virtuele sensoren die luisteren een idx nummer.

via node-red moet ik dus vermoed ik de data uit de iungo converteren naar:
Topic: domoticz/in, Message: {"command":"udevice","idx":658,"svalue":"3.4","nvalue":0}
bijvoorbeeld.

Maar hoe ik die koppeling moet maken, dat gaat mij boven m'n pet.
Rodney heeft in een e-mail aangegeven dat het hem gelukt is, dus ik zal het hem nog eens vragen hoe hij dat gegaan heeft.

Ik ben er bijna! :-)
Helpt dit?: www.domoticz.com/wiki/Flows
En
www.domoticz.com/wiki/MQTT#Update_devices.2Fsensors
Laatst bewerkt: 4 maanden 1 week geleden door P. Meindersma.
The administrator has disabled public write access.

Iungo via mqtt broker koppelen aan Domoticz 1 week 3 dagen geleden #1453

  • JPH Rijntjes
  • JPH Rijntjes's Profielfoto
  • Offline
  • Berichten: 18
  • Ontvangen bedankjes 2
Ik heb net 3 dagen die Raspberry 3B+ stretch. Daarop Mosquitto. Dat werkt ook met subsrciber ontvangen published bericht vanuit andere window. Koppeling van Iungo naar Raspberry benodigd publisher naar broker object. Dat object ook gecreƫerd, maar ik ken niet de topics tree structure van iungo en ook niet het main topic, waarop ik met een wildcard zou kunnen subscriben. De log geeft met een vreemde datum (afwijkend van de juiste datum op de webserver interface) "19-02-10 00:56:47 wrn bus-mqtt Too many MQTT pubs running, dropping message". Da levert me dus geen info over main topic of topic structure.

Graag main topic waarop Iungo publiceert. Verder is ieder praktisch advies is welkom.

Sorry voor de domme vraag met MQTT.fx (eerder in deze draad genoemd inmiddels Topic tree duidelijk).
Laatst bewerkt: 1 week 3 dagen geleden door JPH Rijntjes. Reden: Oplossing gevonden
The administrator has disabled public write access.
Tijd voor maken pagina: 0.100 seconden